[Info-vax] DCL's flaws (both scripting and UI)

David Froble davef at tsoft-inc.com
Fri Jan 23 00:37:17 EST 2015


mcleanjoh at gmail.com wrote:
> On Friday, January 23, 2015 at 8:24:04 AM UTC+11, mcle... at gmail.com wrote:
>> On Friday, January 23, 2015 at 1:17:40 AM UTC+11, Bob Koehler wrote:
>>> In article <m9pdk1$cqh$1 at dont-email.me>, David Froble <davef at tsoft-inc.com> writes:
>>>> I haven't really considered the calls for looping capability.  Perhaps 
>>>> because I do looping in DCL frequently.
>>>>
>>>> Is the problem that there is no formalized looping commands?
>>>    The problem is the large number of programmers I've worked with
>>>    who insist that there is no "goto" in C.
>> It's just simpler and usually clearer to write chunks of DCL that don't have something like
>>
>>
>> LAB$:
> 
> I don't know what happened ... I thought I hit Shift N ...
> 
> It's just simpler and usually clearer to write Loops (FOR, WHILE, DO) instead of chunks of DCL that don't have something like ...
> 
>   N = 1
> LAB_10:
>   N = N + 1
>   IF (N.GE.X) THEN GOTO END_LOOP
>     :
>     :
>   GOTO LAB10
> END_LOOP:
> 
> Compare that to (in a hybrid pseudo code)...
> 
>   FOR N=1; N<X; N++
>      :
>      :
>   END_FOR
> 
> 
> John

First, I'll give you that it's nice to have something more readable.

But, you don't understand that no matter how much you attempt to mask 
it, that there is something like BEQLU or BRW or such at the bottom of 
it all?

Now, in your example above, it's just not that much more effort, and 
it's entirely readable.  Would a looping capability be nice?  Of course 
it would.  But, it's not a game changer or game stopper.

As far as that goes, I'm rather used to For-Next looping, but I know 
people who detest it and insist on While-Next looping.  I use whichever 
works best for each use.  I'm thinking this is a religious argument.



More information about the Info-vax mailing list